openssl1.1安装ruby小于2.4版本失败问题

openssl1.1安装ruby小于2.4版本失败问题

实测macos 10.14系统可以成功,10.15没有成功。

1.我们使用rvm 来安装ruby

2.卸载和清除所有rbenv环境变量和安装数据(包括软件,目录,环境变量)

3.重新安装低版本openssl

1
rvm pkg install openssl
1
rvm reinstall ruby-2.1.10 -C --with-openssl-dir=$HOME/.rvm/usr5.rvm use ruby-2.1.10

4.重新创建gemset

1
rvm gemset create test_gemset

5.使用创建的gemset

1
rvm use ruby-2.1.10@test_gemset

进入项目目录开始 bundle install